Back to overview
Downtime

Admin App Outage Due to Authentication Provider (Clerk) Outage

Jun 26 at 06:45pm NZST
Affected services
getcaruso.com

Resolved
Jun 26 at 06:56pm NZST

The issue with our downstream authentication service provider has been resolved. This issue temporarily affected sign-in to Caruso's Admin App and did not affect the Investor Portal.

Created
Jun 26 at 06:45pm NZST

We are currently experiencing an outage impacting access to the Caruso Admin App. This is due to a global outage with our authentication provider, Clerk, which is preventing users from logging in.

Impact: Admin users are unable to log in or access the admin application.

Current Status: We are closely monitoring Clerk’s status updates and will restore full access as soon as their service is operational. You can track Clerk's status here: https://status.clerk.com

Next Update: We will provide another update within 30 minutes or as soon as we receive new information.