Back to overview
Degraded

Authentication provider outage

May 26, 2026 at 9:35pm UTC
Affected services
getcaruso.com

Resolved
May 26, 2026 at 10:04pm UTC

Clerk has resolved the elevated 500 errors on their API. Sign-in to the Caruso Admin App is now operating normally across all regions. The Investor Portal and API were unaffected throughout.

Created
May 26, 2026 at 9:35pm UTC

Caruso's authentication provider Clerk is reporting elevated 500 errors on their API. This is resulting in intermittent errors signing in to our Admin App across all regions. The Investor Portal and API are unaffected.

We are monitoring and will share an update once Clerk resolves the issue.