Back to overview
Degraded
Admin App intermittent downtime in US region
May 5, 2026 at 11:30pm UTC
Affected services
getcaruso.com
Resolved
May 5, 2026 at 11:55pm UTC
The engineering team released a fix that was rolled out to production 15 minutes ago. Services have maintained stability since deployment, and we are continuing to monitor.
Summary: The Caruso Admin App was experiencing intermittent downtime in the US region of Caruso services. The Investor Portal was not affected.
Affected services
Created
May 5, 2026 at 11:30pm UTC
The Caruso Admin App is experiencing intermittent downtime in the US region of Caruso services. Our engineering team is currently investigating the root cause.
The Investor Portal is not affected.
Affected services